Yesterday's Tractor Co.
Shop Now View Cart
   Allis Chalmers Case Farmall IH Ford 9N,2N,8N Ford
   Ferguson John Deere Massey Ferguson Minn. Moline Oliver
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   Traditional YT Forum ViewClassic View   RegisterRegister 
 ProfileProfile    Log inLog in 

Disconnect, delete, or "loop" my one and only


 
Post new topic    
View previous topic :: View next topic  
Author Message
Cariboo4x4
Long Time User


Joined: 23 Nov 2014
Posts: 606


Report to Moderator

PostPosted: Sun Jun 13, 2021 1:49 pm    Post subject: Disconnect, delete, or "loop" my one and only Reply to specific post Reply with quote

I bought this 1995 gmc sierra. After 4-6 hours of continuous driving I get codes 32 and 44 and engine will lose powe. I decided to simply replaced the pre oxygen sensor. This truck only calls for one o2 sensor. Another problem is a past owner removed catalytic converter. The egr was also sticking open. Since I'm on holidays, I simply replaced egr, vacuum controlled egr. Still the low power starts usually after 4-6 hours of highway driving. The problem starts if I am too long stopped at a light or in a drive through. I simply would just turn truck off. I'm thinking the problem starts with the code 44 for oxygeb sensor whic sends signal to egr via ecm to keep egr open. Egr stays open during stopped at light and only way to solve problem is let truck cool off completely or pull main fuses each time the codes 32 and 44 pop back up. I'm thinking if problem persists after 4-6 hours of continuous highway driving, disconnect vacuum to line that goes to egr and plug it. the new egr will automatically close anmd I won't have exhaust gases dilute clean air at idle.

As for o2 sensor, I can unplug o2 sensor and ecm will receive no voltage at at so not sure what it will do.

I put a block off plate on an older 305 v8 I put in an older truck that didn't have o2 sensor wiring. I know I can go without egr yet thinking if I simply unplug o2 sensor, the only negative is the fuel mileage will decrease.

I simply need to get truck back home to BC from Saskatchewan so I can weld a cat on or figure it out. Been reasearching high and low on net about these single o2 sensor exhaust systems and no help found yet.

Thank you for any help.
 
Back to top
View user's profile
Cariboo4x4
Long Time User


Joined: 23 Nov 2014
Posts: 606


Report to Moderator

PostPosted: Sun Jun 13, 2021 2:33 pm    Post subject: Re: Disconnect, delete, or "loop" my one and only Reply to specific post Reply with quote


Oh my!! I cant believe all my spelling mistakes. I forgot I replaced fuel filter since arriving here in Sask. Before leaving BC I put new air filter and fuel pumptank in truck. All I understand is truck runs awesome for 4-8 hours and then if stopped at a traffic light too long or stopped and engine idles for 10 minutes it has very low power. A stuck or open egr can create this problem I researched. A bad O2 sensor also can cause it. I miss my 1983 GMC gas guzzler. It was so reliable lol. I decided to take this truck because more comfy and has overdrive and cruise. I didnt encounter these problems at home though yet it was short trips. Truck is usibg oil though like a liter every 1000 kms.
 
Back to top
View user's profile
Cariboo4x4
Long Time User


Joined: 23 Nov 2014
Posts: 606


Report to Moderator

PostPosted: Wed Jun 16, 2021 9:38 am    Post subject: Re: Disconnect, delete, or "loop" my one and only Reply to specific post Reply with quote


So drove 3 hours north of where we are staying to pick up a 10x5x5 cargo trailer. On the way back with trailer. It ran really well. Engine light came on once yet I think I have it figured out for now. Remedy: Pull over, turn truck off, sit 5-10 minutes or more and walla! Truck runs normally again. Its like it goes into a limp mode where engine lacks power. Its definitely not tranny.
 
Back to top
View user's profile
Cariboo4x4
Long Time User


Joined: 23 Nov 2014
Posts: 606


Report to Moderator

PostPosted: Sun Jul 04, 2021 8:05 am    Post subject: Re: Disconnect, delete, or "loop" my one and only Reply to specific post Reply with quote


A new MAP sensor seems to have solved issue. I read online the code 32 can also include MAP sensor issue
 
Back to top
View user's profile
:   
Post new topic    Yesterday's Tractors Forum Index -> Yesterday's Trucks All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  

TRACTOR PARTS TRACTOR MANUALS
We sell tractor parts!  We have the parts you need to repair your tractor - the right parts. Our low prices and years of research make us your best choice when you need parts. Shop Online Today. [ About Us ]

YT Home  |  Forums

Modern View Forum powered by phpBB © 2001, 2005 phpBB Group

All Rights Reserved. Reproduction of any part of this website, including design and content, without written permission is strictly prohibited. Trade Marks and Trade Names contained and used in this Website are those of others, and are used in this Website in a descriptive sense to refer to the products of others. Use of this Web site constitutes acceptance of our User Agreement and Privacy Policy

TRADEMARK DISCLAIMER: Tradenames and Trademarks referred to within Yesterday's Tractor Co. products and within the Yesterday's Tractor Co. websites are the property of their respective trademark holders. None of these trademark holders are affiliated with Yesterday's Tractor Co., our products, or our website nor are we sponsored by them. John Deere and its logos are the registered trademarks of the John Deere Corporation. Agco, Agco Allis, White, Massey Ferguson and their logos are the registered trademarks of AGCO Corporation. Case, Case-IH, Farmall, International Harvester, New Holland and their logos are registered trademarks of CNH Global N.V.

Yesterday's Tractors - Antique Tractor Headquarters