Kevin's gibson model a project

Hey all, so I've got this Gibson model a I bought at an auction. It's pretty complete and looks like someone was working on it before they either gave up or are not with us anymore. It didnt have any compression so we've replaced the piston rings, removed the valves and lapped them back in. Now we are working the magneto. Still not getting spark at the moment. I've replaced the coil, condenser, and the cap. The points looked good so I cleaned them up and reset the gap to .015. They were off a hair at .018. I've also disconnected the kill switch wire to eliminate that issue. What else could be going on? How strong should the magnet be? Itll attract a screw driver but barley hold onto it upside down.

From what I've read it should spark even while I rotate the engine by hand. Engine is still currently on the work bench, head still off so I can turn it over pretty easy. Carb is next on the rebuild list, but cant get past this issue.17074463866804577904942227841964.jpg1707446427283411769219888904513.jpg20240122_185301.jpg20231226_171605.jpg
 
Ya it snaps just fine. Made some progress on it though. I cleaned up the spots where the coil mounts and now I've got a spark. It's a weaker spark but its something. Now on to the fuel system.
 
Looking for some help on the govenor to throttle linkage. Anyone have a picture of what's going on in there? My manual shows one thing but I've got another thing going on. I think maybe the manual is showing a stationary engine.20240214_182331.jpg20240214_182412.jpg20240214_182437.jpg
 

We sell tractor parts! We have the parts you need to repair your tractor - the right parts. Our low prices and years of research make us your best choice when you need parts. Shop Online Today.

Back
Top