YM 1502D 3P Won't Lower


New User
I'm new to the forum, new to Yanmars, and new to tractors in general... and I think I've already done something wrong <E>:?</E>

I bought a YM 1502D with only 50 hours on it! From what I can tell, I'm actually the 4th owner, and the first owner was a collector who kept the tractor in a garage/barn its entire life. The next 2 owners were somewhat in-over-their-heads, and so they didn't use it much. I mention this because the tractor has gotten almost <I><s></s>no<e></e></I> use through its life.

The first day I had it, I raised the 3P which has a rake attached to it, closed the valve under the seat, and went about my business. At the end of the day, I parked it with the 3P still in the air, and the valve under the seat closed. I left it that way for ~1 week. Now, the 3P won't go down. I've tried opening the valve, closing it tighter, then opening it, revving the engine higher, standing on the rake... it won't budge. I can hear the bypass valve open when I try to raise it, as it's already raised, so I know <I><s></s>something<e></e></I> about the hydraulics works. It also worked perfectly (raise &amp; lower) when I first got it.

My best guess is that while the knob under the seat is unscrewed/open, the valve isn't actually open. Is there a relief screw or something I can open to let the 3P back down again? Any thoughts on how to fix this are welcomed... thanks in advance!
Don't know if you are aware but the 1502 is and import or grey market Yanmar. It likely had hours on it before it made it over seas to you. Some of the so called refurbishers ran the hour meters back. Not saying yours was, but also not sure I would believe real low hours. No matter, lot's of good used grey market Yanmars in service here in the US.

I would suspicion two possibilities. Stop valve became unassembled internally, or lift piston stuck in up position.

I do not have access to a 1502 manual so can't comment on letting pressure off. I don't know how much weight you have on the thee point but you might consider hitting down on the 3 point arms. (not hard enough to break something, just hard enough to possibly free a stuck piston)

Keep us informed of your progress.
Winston, thanks for the reply!

I didn't realize there were refurbishers that would wind the hours back... that's slightly disheartening. However, given how well everything works (except the hydraulics), it doesn't really matter as you say.

I ended up leave the lever on "lower" and the valve open, and when I started it today, I was able to get it to lower! So I'm thinking the stop valve did get stuck, but "unstuck itself" by sitting with pressure on it... honestly don't know, but am happy it's working now. On to the next, related problem...

The hydraulics on the front dumper jitter when I raise them. If I have a load in the front, and try to raise it while uncurling it (basically 2 hydraulic motions at once), the dumper will fall. The same with the 3PH on the back... when I take the slightest bit of "raise pressure" off it, it'll fall ~6" or so.

From all the videos I've watched, everyone is pointing me towards the screen filter. I'll start there, but the fluid in the transmission is crystal clear. However, I do see tiny bubbles in there, so I'm wondering if the system is sucking in air somewhere, and that's causing fluid flow issues. Is this common on the 1502 (or 1500, as I believe it's similar)? Other common problems that would cause weak and jerky hydraulics?

Thanks again!
Your symptoms could be air in system. Not many places air can enter, only on the suction side of the pump. Not for sure on your 1502, but I think the suction line going to your pump has a rubber coupling. See #14 in this drawing for an idea. You have a spin on hydraulic filter as well as a suction screen. I am not sure of the location of the screen on your 1502. Checking for suction leaks and clean filter and strainer would be the place to start.
Finally got a warm night to work on the tractor a little. Happy to post under a different title, as the subject has a changed a bit.

As I mentioned, I'm trying to diagnose weak hydraulics that also cavitate or "pulse" sometimes when I use them. I took the spin-on filter off, and went looking for the screen filter. I was not able to find the screen filter... or at least nothing in the transmission case, which is where I'd expect to find it:

<ATTACHMENT filename="tractor_filter.jpg" index="0"><s>[attachment=0]</s>tractor_filter.jpg<e>[/attachment]</e></ATTACHMENT>

I looked up the spin-on filter that was on it, and it is rated at 5 microns: https://www.grainger.com/product/2KZK3 From what I was reading <s>[url=http://ymowners.com/phpbb/viewtopic.php?p=38425#p38425]</s>here<e></e>[/URL], this is way too small. It should be between 25 and 30, correct? Any filter recommendations?

I'm also planning on replacing the hydraulic fluid, as it's pretty dark. Given <s>[url=http://ymowners.com/phpbb/viewtopic.php?f=2&amp;t=580]</s>this post<e></e>[/URL], I'm assuming the recommendation is simply any J20A fluid, like this: <LINK_TEXT text="https://www.extern...ity-tractor-fluid-5-gal-vp2040114</LINK_TEXT>

Winston, that image is the left side... so I'm guessing I just don't have one any more. That opening you see is going into the transmission, which is where I'd expect to find such a screen.

Thanks for the filter recommendation. As for fluid... J20 I assume? Thanks again!
Yes on fluid. I just assumed the screw on filter threads in the picture were on the right hand side. I thought alll the YM series with screw on filters had the filter housing on the right hand side. I probably don't know what I am looking at. <E>:mrgreen:</E>
Here's another picture.

<ATTACHMENT filename="tractor.jpg" index="0"><s>[attachment=0]</s>tractor.jpg<e>[/attachment]</e></ATTACHMENT>

The screw-on is on the left side, as you sit in the seat. The 3-bolt panel is behind the screw-on filter, as can be seen in the other picture. So yea, I guess it's just missing.

I also am having the same problem with my YM 2010D. I changed the hydraulic fluid and also opened up the left side (looking down from sitting on the seat) thinking I would find a screen. Nothing there, so I put it all back together and still nothing. I can get about 3 inches of lift at the very top end with the rear 3point lift. It lowers about 3 inches and then stops. My brush hog is still 6-8 inches in the air.

How do I bleed the air out of the hydraulic fluid? Also, there is a small threaded hole at the top of the 3point (hidden under the seat) I think it should have a plug or bolt in it?? Is this supposed to be a breather type bolt?

Thank you,
Winston, thank you for your answer. Any ideas why the 3point won't lower all the way back down? I took the small plate off the side of the hydraulic fluid tank (where I found the drain plug) and there was not a screen in it (I've been reading everywhere that there should have been). Wondering if I looked in the wrong spot.

Thank you,
I'm less than a shade tree mechanic, just trying to get it going again.
<ATTACHMENT filename="2023-05-15-061333.jpg" index="0"><s>[attachment=0]</s>2023-05-15-061333.jpg<e>[/attachment]</e></ATTACHMENT>I am uncertain where to look on the 2010. I have a parts manual for the 2010, it shows the strainer but not able to tell just what it is behind.
Does all your external linkage on the 3 point control seem to be intact and moving as it should?

Any idea whether something mechanical or something in the hydraulics that is holding the lift from going down? How much movement are you getting up and down? Any chance of doing a video?


We sell tractor parts! We have the parts you need to repair your tractor - the right parts. Our low prices and years of research make us your best choice when you need parts. Shop Online Today.